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Creo Parametric 4.0: A Power Guide for Beginners and Intermediate Users textbook is

designed for instructor-led courses as well as self-paced learning. It is intended to help

engineers and designers interested in learning Creo Parametric for creating 3D mechanical

design. This textbook benefits new Creo users and is a great teaching aid in classroom

training. It consists of 12 chapters, total 720 pages covering the major modes of Creo

Parametric such as the Sketch, Part, Assembly, and Drawing modes. The textbook teaches

users to use Creo Parametric mechanical design software for building parametric 3D solid

components, assemblies, and 2D drawings.This textbook not only focuses on the usages of the

tools/commands of Creo Parametric but also on the concept of design. Each chapter of this

textbook contains tutorials which help users to easily operate Creo Parametric step-by-step.

Moreover, each chapter ends with hands-on test drives which allow users to experience the

user friendly and technical capabilities of Creo Parametric.Table of Contents:Chapter 1.

Introduction to Creo ParametricChapter 2. Drawing Sketches and Applying DimensionsChapter

3. Editing and Modifying SketchesChapter 4. Creating Base Feature of a Solid ModelChapter 5.

Creating Datum GeometriesChapter 6. Advanced Modeling - IChapter 7. Advanced Modeling -

IIChapter 8. Patterning and MirroringChapter 9. Advanced Modeling - IIIChapter 10. Working

with Assemblies - IChapter 11. Working with Assemblies - IIChapter 12. Working with

DrawingsMain Features of the TextbookComprehensive coverage of toolsStep-by-step real-

world tutorials with each chapterHands-on test drives at the end of each chapter to enhance

the skillsAdditional notes and tipsCustomized content for faculty (PowerPoint

Presentations)Free learning resources for faculty and studentsTechnical support for the book

by contacting info@cadartifex.com
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1SummaryQuestionsPrefaceCreo Parametric, developed by PTC Inc. (Parametric Technology

Corporation) is one of the biggest technology providers to engineering, which offers a complete

range of 3D software tools that let you create, simulate, publish, and manage your design data.

By providing advanced solid modeling techniques and field proven technology, PTC enables its

customers to stay one step ahead the even increasing competition with its strategic vision. PTC



helps companies to quickly adopt changes that are being created at the convergence of the

physical and digital worlds through IoT, 3D printing, digital twin, and augmented reality.Creo

Parametric delivers a rich set of integrated tools that are powerful and intuitive to use. It is a

feature-based, parametric solid-modeling mechanical design and automation software which

allows you to convert 2D sketches into solid models by using simple yet highly effective

modeling tools. Creo Parametric provides a wide range of tools that allow you to create real-

world components and assemblies. These real-world components and assemblies can then be

converted into 2D engineering drawings for production, additive manufacturing, IoT, and model-

based definition (MBD). Additionally, you can validate your designs by simulating their real-

world conditions and assessing their environmental impact of products.Creo Parametric 4.0: A

Power Guide for Beginners and Intermediate Users textbook is designed for instructor-led

courses as well as self-paced learning. It is intended to help engineers and designers

interested in learning Creo Parametric for creating 3D mechanical design. This textbook

benefits new Creo users and is a great teaching aid in classroom training. It consists of 12

chapters, total 720 pages covering the major modes of Creo Parametric such as the Sketch,

Part, Assembly, and Drawing modes. The textbook teaches users to use Creo Parametric

mechanical design software for building parametric 3D solid components, assemblies, and 2D

drawings.This textbook not only focuses on the usages of the tools/commands of Creo

Parametric but also on the concept of design. Each chapter of this textbook contains tutorials

which help users to easily operate Creo Parametric step-by-step. Moreover, each chapter ends

with hands-on test drives which allow users to experience the user friendly and technical

capabilities of Creo Parametric.Who Should Read This BookThis book is written with a wide

range of Creo Parametric users in mind, varying from beginners to advanced users and Creo

Parametric instructors. The easy-to-follow chapters of this book allow you to easily understand

different design techniques, Creo Parametric tools, and design principles.What Is Covered in

This TextbookCreo Parametric: A Power Guide for Beginners and Intermediate Users textbook

is designed to help you understand everything you need to know to start using Creo

Parametric with clear step-by-step tutorials. This textbook covers the following:Chapter 1,

“Introduction to Creo Parametric,” introduces Creo Parametric interface, different Creo

Parametric modes, and various components of startup user interface. It also explains how to

set the working directory, erase objects of the current session, save an object, open an object,

delete older versions of a design, change background color, customize the Ribbon and Quick

Access Toolbar, and close a file.Chapter 2, “Drawing Sketches and Applying Dimensions,”

discusses how to invoke the Sketching environment, specify units, define grids and snaps

settings, draw sketches, create datum geometries, work with construction mode, apply

constraints, work with weak dimensions, apply dimensions, and edit dimensions.Chapter 3,

“Editing and Modifying Sketches,” introduces various editing tools for editing and modifying

sketch entities. It also explains how to insert a pre-defined shape of geometry, a sketch, or a

drawing file in the Sketching environment.Chapter 4, “Creating Base Feature of a Solid Model,”

discusses how to create 3D solid and thin extrude features as well as revolve base features of

a model. It also explains how to navigate a model by using the mouse buttons and the

navigating tools, manipulate the view orientation of the model to the predefined standard

views, and change the display style of a model.Chapter 5, “Creating Datum Geometries,”

introduces three default planes: Front, Top, and Right. As these may not be enough for creating

models having multiple features therefore, the chapter discusses how to create additional

datum planes. Additionally, this chapter also explains creating a datum axis, datum coordinate

system, and datum point.Chapter 6, “Advanced Modeling - I,” introduces advanced options for



creating extruded and revolved features. The chapter discusses how to create cut features,

project the edges of existing features onto the current sketching plane, edit an existing feature

and the sketch of a feature, and measure different geometrical parameters such as length,

angle, area, and volume. It also explains assigning appearances, material, and calculating the

mass properties of a model.Chapter 7, “Advanced Modeling - II,” discusses how to create

sweep features, helical sweep features, blend features, swept blend features and rotational

blend features.Chapter 8, “Patterning and Mirroring,” introduces various patterning and

mirroring tools. After successfully completing this chapter, you can create different type of

patterns such as dimension pattern, direction pattern, axis pattern, fill pattern, table pattern,

reference pattern, curve pattern, variable pattern, and geometry pattern. Also, you can mirror a

feature or features about a mirroring plane as well as copy and paste a feature.Chapter 9,

“Advanced Modeling - III,” discusses how to create simple holes using a predefined rectangle

profile, a standard hole profile (countersink, counterbore, or tip angle), and a sketched profile. It

explains how to create industry-standard holes such as tapped, tapered, drilled, and clearance

as per the standard specifications. This chapter also explains creating cosmetic threads,

various types of rounds, chamfers, profile ribs, trajectory ribs, and shell features.Chapter 10,

“Working with Assemblies - I,” discusses how to create assemblies by using the bottom-up

assembly approach and how to apply predefined constraint sets such as Pin, Slider, Cylinder,

and Planar. It explains how to apply user defined constraints such as Distance, Angle Offset,

Parallel, and Coincident to assemble the components of an assembly. This chapter also

elaborates moving and rotating individual components of an assembly as well as editing

constraints.Chapter 11, “Working with Assemblies - II,” discusses how to create assemblies by

using the top-down assembly approach. It explains how to edit a component of an assembly

within the Assembly environment or by opening the component in the Part modeling

environment. It introduces the editing of existing constraints, displaying constraints and

features of components in the Model Tree of the Assembly mode, and patterning and mirroring

assembly components. The chapter elaborates the creation of assembly features, suppressing

or resuming the components of an assembly, inserting multiple copies of a component in an

assembly, checking interference between components, creating exploded view of an assembly,

switching between exploded and unexploded views of an assembly, and creating the Bill of

Material (BOM).Chapter 12, “Working with Drawings,” discusses how to create 2D drawings

from parts and assemblies. It introduces various drawing views such as general views,

projection views, section views, auxiliary views, and detailed views of a component or an

assembly, along with the concept of angle of projections. This chapter also explains defining

the angle of projection, creating a new drawing template or format, applying reference and

driving dimensions, modifying drawing properties, editing hatching and text style of a view, and

adding notes, bill of material (BOM), and balloons.Icons/Terms used in this TextbookThe

following icons and terms are used in this textbook:NoteNOTE: Notes highlight information

requiring special attention.TipTIP: Tips provide additional advice, which increases the

efficiency of the users.New New icons highlight new features of this release.Updated Updated

icons highlight updated features of this release.FlyoutA Flyout is a list in which a set of tools

are grouped together, see Figure 1.Drop-down ListA drop-down list is a list in which a set of

options are grouped together, see Figure 2.FieldA Field allows you to enter new value, or

modify an existing/default value, as per your requirement, see Figure 2.Check boxA Check box

allows you to turn on or off the usage of a particular option, see Figure 2.ButtonA Button

appears as a 3D icon and allows you to turn on or off the function of a particular option.How to

Contact the AuthorWe welcome your valuable feedback and suggestions. Please email us at



info@cadartifex.com. You can also login to our website www.cadartifex.com and write your

feedback about the textbook as well as download the free learning resources.Thank you very

much for purchasing Creo Parametric 4.0: A Power Guide for Beginners and Intermediate

Users textbook, we hope that the information and concepts introduced in this textbook help you

to accomplish your professional goals.Chapter 1Introduction to Creo ParametricIn this chapter,

you will learn the following:• Installing Creo Parametric• Getting Started with Creo Parametric•

Starting a New File• Setting the Working Directory• Identifying Creo Parametric Files• Erasing

Objects of the Current Session• Saving an Object• Saving a Copy of an Object• Opening an

Object• Deleting Older Versions of a Design• Changing Background Color• Customizing the

Ribbon• Customizing the Quick Access Toolbar• Closing a FileWelcome to the world of

Computer Aided Design (CAD) with Creo Parametric. It is the product of PTC Inc. (Parametric

Technology Corporation), one of the biggest technology providers to engineering, which offers

a complete range of 3D software tools that let you create, simulate, publish, and manage your

design data. By providing advanced solid modeling techniques and field proven technology,

PTC enables its customers to stay one step ahead the even increasing competition with its

strategic vision. PTC helps companies to quickly adopt changes that are being created at the

convergence of the physical and digital worlds through IoT, 3D printing, digital twin, and

augmented reality.Creo Parametric delivers a rich set of integrated tools that are powerful and

intuitive to use. It is a feature-based, parametric solid-modeling mechanical design and

automation software which allows you to convert 2D sketches into solid models by using

simple yet highly effective modeling tools. Creo Parametric provides a wide range of tools that

allow you to create real-world components and assemblies. These real-world components and

assemblies can then be converted into 2D engineering drawings for production, additive

manufacturing, IoT, and model-based definition (MBD). Additionally, you can validate your

designs by simulating their real-world conditions and assessing their environmental impact of

products.Installing Creo ParametricIf you do not have Creo Parametric installed on your

system, you first need to get it installed. However, before you start installing Creo Parametric,

you need to evaluate the system requirements and make sure it is capable of running Creo

Parametric adequately. Below are the system requirement for installing Creo Parametric.1.

Operating Systems: Windows 10, 8.1, or 7 SP1 - 64-bit only2. RAM: Minimum 512 MB (4 GB or

higher recommended)3. Disk Space: Minimum 400 MB (10 GB or more recommended)4.

Processor: Intel Pentium (4, M, D), Intel Xeon, Intel Celeron, Intel Core, AMD Athlon, AMD

Opteron (Single-, dual- and quad-core processors are supported)5. Graphics Card: 3D capable

graphics card with OpenGL supportFor more information about the system requirement for

Creo, visit PTC website at https://www.ptc.com/en/products/cad/elements-direct/modeling/

express/system-requirementsOnce the system requirements have been fulfilled, install Creo

Parametric software by using the downloaded Creo Parametric setup files.Getting Started with

Creo ParametricOnce Creo Parametric is installed on your system, start by double-clicking on

the Creo Parametric icon on the desktop of your system. As soon as you double-click on the

Creo Parametric icon, the system prepares for start-up by loading all the required files. Once

all the required files have been loaded, the startup user interface of Creo Parametric appears

along with the Resource Center window, see Figure 1.1. The Resource Center window is used

for accessing online Creo resources, PTC Communities, PTC Event, and so on. If you do not

want this window to be displayed next time you start Creo Parametric, select the Do not show

window again check box in the bottom of the Resource Center window. Next, close the

Resource Center window. The startup user interface of Creo Parametric appears as shown in

Figure 1.2.TIP: If the display of the Resource Center window is turned off, then you can turn on



its display by clicking on File > Help > Online Resources in the File menu and then selecting

the Do not show window again check box at the bottom of the Resource Center window that

appears.It is evident from the startup user interface of Creo Parametric that it is very user-

friendly and simple to operate. Some of the components of the startup user interface of Creo

Parametric are discussed below:NavigatorThe Navigator is available on the left side of the

screen and consists of three tabs: Model Tree, Folder Browser, and Favorites, see Figure 1.3.

The Model Tree tab is enabled only when a model is opened in Creo Parametric and displays

the Model Tree which keeps a record of all operations or features used for creating the model.

You will learn more about the Model Tree later in this chapter. The Folder Browser tab displays

a list of folders available in your local computer. It allows you to quickly access any folder of

your system. The Favorites tab allows you to access files that are saved in the Personal

Favorites folder. Note that you can turn on or off the display of Navigator by clicking on the

Show Navigator button available at the lower left side of the Status Bar.BrowserIn Creo

Parametric, when you start a new session, the Browser appears on the screen with three tabs,

refer to Figure 1.2. The Creo | PTC tab is linked to the start page of PTC (https://www.ptc.com/

en/creo/start-page). This page allows you to access online learning resources such as getting

started topics and support. The PART community 3D CAD manufacturer tab is linked to the

PTC community page (http://ptc.partcommunity.com/). This pages allows you to access the

PTC online community portal that offers certified 2D and 3D models from global manufactures.

The 3D ModelSpace tab is linked to the PTC 3D model space library page (http://

www.3dmodelspace.com/ptc). This page allows you to download 3D standard models. You can

switch between the tabs and browse to any URL or web page similar to other internet

explorer.RibbonThe Ribbon is available at the top of the screen and is composed of a series of

tabs in which a set of similar tools are grouped together in different groups, see Figure 1.4.

Note that in the startup user interface of Creo Parametric, only the Home tab is available in the

Ribbon. You will learn more about the Ribbon later in this chapter. By using the tools in the

Data group of the Home tab, you can start a new file, open an existing file, open last session,

specify working directory, and erase objects that are not displayed in the current session of

Creo Parametric. These are discussed next.Starting a New FileIn Creo Parametric, you can

start a new file by using the New tool of the Data group in the Home tab, refer to Figure 1.4.

You can also access the New tool in the File menu and the Quick Access Toolbar, see Figures

1.5 and 1.6.To start a new file, click on the New tool or press CTRL + N. The New dialog box

appears, see Figure 1.7. In this dialog box, you can select the type and sub-type of the file to

be started. By default, the Part radio button is selected in the Type area and the Solid radio

button in the Sub-type area of the dialog box. As a result, on clicking the OK button in the

dialog box, the Part mode will be invoked for creating a 3D solid part. The methods for invoking

the Part mode, Assembly mode, and Drawing mode by using the New dialog box are discussed

next.Invoking the Part ModeTo invoke the Part mode for creating a 3D solid part, make sure

that the Part radio button is selected in the Type area and the Solid radio button in the Sub-

type area of the New dialog box. Next, specify a name of the part in the Name field of the

dialog box. By default, the Use default template check box is selected in the dialog box. As a

result, the default Creo template (inlbs_part_solid) with predefined unit system (length in

inches, mass in lbm, and time in seconds) is used for creating the part. To select a template

other than the default one, clear the Use default template check box in the dialog box and then

click on the OK button. The New File Options dialog box appears, see Figure 1.8.In the New

File Options dialog box, select the required template and then click on the OK button in the

dialog box. The Part mode is invoked and the startup user interface of the Part mode appears,



as shown in Figure 1.9.It is evident from the startup user interface of the Part mode that Creo

Parametric is very user-friendly. Some of the components of the startup user interface are

discussed next.RibbonThe Ribbon is available at the top of the graphics window and it

composed of a series of tabs such as Home, Analysis, and Annotate in which a set of similar

tools are grouped together in different groups, see Figure 1.10. Note that the availability of

tabs, groups, and tools in the Ribbon depends upon the currently invoked mode of Creo

Parametric.You can also minimize the Ribbon to increase the size of the graphics window. For

doing so, right-click anywhere in the Ribbon and then select the Minimize the Ribbon check

box in the shortcut menu that appears, see Figure 1.11.Quick Access ToolbarThe Quick

Access Toolbar is provided with frequently used tools such as New, Open, Save, Save As,

Undo, Redo, and Regenerate, see Figure 1.12. It is available at the top of the Ribbon.File

MenuYou can invoke the File menu by clicking on the File button available at the top left corner

of the Ribbon, see Figure 1.13. It contains tools for starting a new file, opening an existing file,

saving a file, closing a file, managing a file, preparing a model for distribution, managing the

current session of Creo Parametric, and setting Creo Parametric options and configurations.

You can also access the recently opened files by using the File menu.In-graphics ToolbarThe

In-graphics toolbar is available at the top middle end of the graphics window, see Figure 1.14. It

is provided with different sets of tools that are used for manipulating the view and display of a

model available in the graphics window.Model TreeThe Model Tree appears on the left side of

the graphics window and keeps a record of all operations or features used for creating a

model, see Figure 1.15. Note that the first created feature appears at the top and the next

created features appear one after the other in an order in the Model Tree. Note that in the

Model Tree, three default datum planes and a coordinate system appear by default.Status

BarThe Status Bar is available at the bottom of the graphics window and provides information

about the action to be taken based on the currently active tool. It also contains tools to toggle

the display of full screen mode, Navigator, and Browser, see Figure 1.16. You can also filter the

selection mode by selecting the required option in the Filter drop-down list of the Status

Bar.Invoking the Assembly ModeThe Assembly mode is used for creating assemblies. To

invoke the assembly mode for creating an assembly, click on the New tool in the Quick Access

Toolbar or press the CTRL + N key. The New dialog box appears. In this dialog box, select the

Assembly radio button in the Type area and the Design radio button in the Sub-type area. Next,

specify a name of the assembly in the Name field of the dialog box. By default, the Use default

template check box is selected in the dialog box. As a result, the default Creo template with the

predefined unit system is used for creating the assembly. To select a template other than the

default one, clear the Use default template check box in the dialog box and then click on the

OK button. The New File Options dialog box appears. In this dialog box, select the required

template and then click on the OK button. The Assembly mode is invoked and the startup user

interface of the Assembly mode appears, as shown in Figure 1.17.After invoking the Assembly

mode, you can create an assembly by assembling two or more than two components. Figure

1.18 shows an assembly. You will learn more about creating assemblies in later

chapters.Invoking the Drawing ModeThe Drawing mode is used for creating 2D drawings of a

component or an assembly. To invoke the Drawing mode, click on the New tool in the Quick

Access Toolbar or press the CTRL + N key. The New dialog box appears. In this dialog box,

select the Drawing radio button in the Type area and then enter a name of the drawing file in

the Name field of the dialog box. Next, clear the Use default template check box in the dialog

box to select the required drawing template and then click on the OK button. The New Drawing

dialog box appears, see Figure 1.19. The options in the New Drawing dialog box are used for



defining a drawing template to create drawing views. You can define a default template, a

format, or an empty template by selecting the required radio button in the Specify template

area of the dialog box. After specifying the required drawing template, click on the OK button in

the dialog box. The Drawing mode is invoked and the startup user interface of the Drawing

mode appears, as shown in Figure 1.20.After invoking the Drawing mode, you can generate

various drawing views of a component or an assembly. You will learn about generating various

drawing views, applying dimensions, creating BOM, and so on in later chapters. Figure 1.21

shows a drawing with dimensions for your reference only.Identifying Creo Parametric FilesThe

files or models created in different modes (Sketch, Part, Assembly, and Drawing) of Creo

Parametric have different file extensions, see the table given below:ModeFile Extension /

FormatSketch mode.secPart mode.prtAssembly mode.asmDrawing mode.drwTIP: You can

invoke the Sketch mode for creating a sketch by selecting the Sketch radio button in the Type

area of the New dialog box. Besides, you can also invoke the sketch mode within the Part

mode of Creo Parametric. You will learn about creating sketches in later chapters.Setting the

Working DirectoryAfter starting Creo Parametric, it is important to first set a working directory

for saving the files of the current session of Creo Parametric. You can set any folder created in

a local drive of your system as the working directory. However, it is recommended to set a

working directory such that all the files of a project are saved in a common folder for making it

easier to manage and avoid missing components of an assembly or a drawing file.To set a

working directory, click on File > Manage Session > Select Working Directory in the File menu,

see Figure 1.22. The Select Working Directory window appears. In this window, browse to the

required location of a local drive of your system and then select the desired folder as the

working directory. Next, click on the OK button in the dialog box. The selected folder becomes

the working directory for saving all the files of the current session of Creo

Parametric.Alternatively, to set the working directory, click on the Working Directory folder of

the Folder Browser tab in the Navigator that appears on the left side of the screen when you

start a new session of Creo Parametric, see Figure 1.23. A list of folders appears in the

Browser. Next, browse to the required location and then select the desired folder. The selected

folder becomes the working directory of the current session of Creo Parametric.You can also

click on the Working Directory tool in the Data group of the Home tab that appears in the

Ribbon when you start a new session of Creo Parametric to set the working directory, see

Figure 1.24.Erasing Objects of the Current SessionAll the files that you create or open in the

current session of Creo Parametric are saved in the temporary memory even after the file is

currently closed. As a result, Creo Parametric does not allow you to specify a name for a file

that was previously used in the session. Also, when you open an assembly, the previously

created or opened components in the session will be opened, if the names of the components

being opened are matched with them.To overcome this issue, it is recommended to remove all

the files from the temporary memory that are not currently displayed in the current session of

Creo Parametric. For doing so, click on the File > Manage Session > Erase Not Displayed in

the File menu. The Erase Not Displayed dialog box appears with a list of all the objects that are

not displayed in the current session, see Figure 1.25. Next, click on the OK button in the dialog

box. All the objects are removed from the temporary memory.You can also remove or erase the

object that is currently displayed in the current session of Creo Parametric. For doing so, click

on File > Manage Session > Erase Current in the File menu. The Erase Confirm dialog box

appears, see Figure 1.26. Click on the Yes button in this dialog box to confirm the action of

erasing the current object from the session.Saving an ObjectTo save an object, click on the

Save tool in the Quick Access Toolbar or press the CTRL + S key. The Save Object dialog box



appears such that it gets browsed to the folder which is defined as the working directory. Also,

the name of the object appears in the Model Name field of the dialog box. Next, click on the OK

button in the dialog box. The object is saved in the specified working directory.In Creo

Parametric, every time you save an object by using the Save tool, a new version of the object is

saved in the working directory because Creo Parametric keeps track of each version of your

design and saves them as backup files. However, when you open an object, the latest version

of the file gets opened in Creo Parametric. After completing the design, you can delete all the

older versions of your design from the hard disk of your computer except the latest version.

The methods for opening an object and deleting all the older versions of a design are

discussed later in this chapter.Saving a Copy of an ObjectIn Creo Parametric, you can save a

copy of an object in the same or different working directory. For doing so, make sure that the

object is opened in the current session of Creo Parametric. Next, click on the File > Save As >

Save a Copy in the File menu. The Save a Copy dialog box appears. In this dialog box, browse

to the location where the copy of the object is to be saved and then specify a new name for the

copy of the object in the File Name field of the dialog box. Next, click on the OK button. A copy

of the object is saved in the native Creo Parametric file format in the specified location.You can

also save or export an object to other file format such as Inventor file, CATIA file, NX file,

SolidWorks file, IGES file, STEP file, Neutral file, PDF file, etc. For doing so, click on the File >

Save As > Save a Copy in the File menu. The Save a Copy dialog box appears. In the Type

drop-down list of the dialog box, select the required file format in which you want to export the

object, see Figure 1.27. You can scroll down in the Type drop-down list to access more options.

After selecting the file format, browse to the required location and then specify a new name for

the object in the File Name field of the dialog box. Next, click on the OK button. A copy of the

object is saved in the selected file format.Opening an ObjectTo open an object in Creo

Parametric, click on the Open tool in the Quick Access Toolbar or press the CTRL + O key. The

File Open dialog box appears. In this dialog box, the Creo Files

(.prt, .asm, .drw, .frm, .mfg, .lay, .sec, .int, .g, .tmz, .cem) option is selected in the Type drop-

down list, by default. As a result, the objects that are saved in the native Creo Parametric file

format appear in the dialog box. Next, select the object to be opened and then click on the

Open button in the dialog box. The selected object is opened in the current session of Creo

Parametric.NOTE: In Creo Parametric, when you open an object, the latest version of the file

gets opened. To open an older version of a design, invoke the File Open dialog box by clicking

on the Open tool. Next, browse to the location where the object to be opened is saved. By

default, only the latest version of the object appears in the File Open dialog box. To display all

versions of the design, invoke the Tools flyout in the File Open dialog box and then select the

All Versions check box, see Figure 1.28. All the versions of the design appear in the dialog box.

Next, select the required version and then click on the Open button in the dialog box. The

selected version of the design gets opened in Creo Parametric.
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